+ Reply to Thread
Page 2 of 2
FirstFirst 1 2
Results 11 to 17 of 17

Thread: PTT Anyone have GOOD LUCK?!

  1. Join Date
    Jan 2002
    Posts
    2,861
    Downloads
    3
    Uploads
    0

    These clutches are noisy with the pedal down and when engaging.

    If you adjust the rod to get rid of the noise, you're not getting full release and things are now dragging.

    I've been running PTT twins for a long time.

    I was part of the original test group for them.
    - 758/636 uncorrected @ English Racing, Nov 2011

  2. Join Date
    Jan 2002
    Posts
    2,861
    Downloads
    3
    Uploads
    0

    These clutches are noisy with the pedal down and when engaging.

    If you adjust the rod to get rid of the noise, you're not getting full release and things are now dragging.

    I've been running PTT twins for a long time.

    I was part of the original test group for them.
    - 758/636 uncorrected @ English Racing, Nov 2011

  3. Then come to my house and tell me why my 3rd set is grinding......... I know the first 2 was cause of the inner splines wearing out (prior to hardened hubs), now the 3rd set (hardened hubs) after 100-200 miles is grinding AGAIN!!!!!!!!! grrrrrrrrrrrrrrrr, but it isn't dragging (as far as my tests show), I sit in gear and do either stutter box or just rev over 7k and car doesn't move. Wierdest thing, I adjust my peddle rod and the release point DOES NOT change.
    Joe
    2003 Blk/Mod Red Z06
    (Blackwing CAI and Borla catback)
    12.9@109
    1997 Talon TSI AWD
    11.084@128.43 on E85
    WIFE'S NEW CAR!!!
    2007 Yukon XL Denali (every single bell and whistle)
    (Stock..... Gotta have a way to get the kids around)

    http://www.siliconeintakes.com/

  4. Join Date
    Jan 2002
    Posts
    2,861
    Downloads
    3
    Uploads
    0

    It's either dragging or your 3rd gear syncros are worn.

    What kind of fluid are you using?
    - 758/636 uncorrected @ English Racing, Nov 2011

  5. Join Date
    Jan 2002
    Posts
    2,861
    Downloads
    3
    Uploads
    0

    It's either dragging or your 3rd gear syncros are worn.

    What kind of fluid are you using?
    - 758/636 uncorrected @ English Racing, Nov 2011

  6. 3rd set (of PTT discs) not 3rd gear, lol, but I used to use BG II, but as per Jon's (TRE Jon) recomendation I switched to redline 90 (the yellow one). And it's my 2nd gear (only upshift) and 4th gear (only downshift) that grinds....... and all syncos have the same 100-200 miles on them, they were replaced when my input shaft was replaced all while waiting for my new clutch from PTT.
    Joe
    2003 Blk/Mod Red Z06
    (Blackwing CAI and Borla catback)
    12.9@109
    1997 Talon TSI AWD
    11.084@128.43 on E85
    WIFE'S NEW CAR!!!
    2007 Yukon XL Denali (every single bell and whistle)
    (Stock..... Gotta have a way to get the kids around)

    http://www.siliconeintakes.com/

  7. Join Date
    Mar 2007
    Location
    otis colorado
    Posts
    58
    Downloads
    2
    Uploads
    0

    my bad, i thought i had the ptt but i actually have the qm twin disc. from what i understand they are the same, but my issue was having the discs on the wrong way. i had the flat surfaces facing the tranny. now that its switched, everything works fine even with the stock slave cylinder. thanks for the replies.

+ Reply to Thread

Similar Threads

  1. Great Luck
    By mrmegnum in forum Misc
    Replies: 8
    Last Post: 02-23-2007, 10:37 PM
  2. Just my luck...
    By KeltonDSMer in forum Off Topic
    Replies: 1
    Last Post: 08-16-2006, 05:16 PM
  3. good enough?
    By v413nc3 in forum Misc
    Replies: 7
    Last Post: 03-20-2003, 11:38 AM
  4. so tell me good or bad?
    By MDUBUGSX in forum Colorado Springs Area
    Replies: 30
    Last Post: 03-13-2003, 07:45 AM
  5. good bye
    By hoffman in forum Off Topic
    Replies: 6
    Last Post: 07-12-2002, 09:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts